Greengage - SEPA Payment Delays – Incident details

All systems operational

SEPA Payment Delays

Resolved
Degraded performance
Started over 2 years agoLasted about 1 hour

Affected

Payments & Card Service

Degraded performance from 4:58 PM to 6:23 PM

Updates
  • Resolved
    Resolved

    Our payments provider has now confirmed that the issue with SEPA payments has been resolved.

    Any payments impacted during this issue, which fell into a pending status will continue to be remediated moving forward.

  • Identified
    Identified

    An issue was identified by our Payments provider with SEPA outbound and inbound payments remaining in a pending status causing some delays with payments. This is due to an outage with their screening provider.