Greengage - SEPA Credit Transfer Payment Delay – Incident details

All systems operational

SEPA Credit Transfer Payment Delay

Resolved
Degraded performance
Started over 2 years agoLasted about 3 hours

Affected

Payments & Card Service

Degraded performance from 8:29 AM to 11:47 AM

Updates
  • Resolved
    Resolved

    We can confirm the incident has now been resolved. Any payments pending from this morning should now be processed.

  • Investigating
    Investigating

    Our Payments Provider is currently investigating a delay to outbound Euro payments being processed by SEPA Credit Transfer for our European accounts. Outbound SEPA Instant Payments are still being processed normally.

    There is no Impact to Inbound SEPA payments.

    We will update as soon as more information or a resolution is reached.