Scheduled for March 17, 2024 at 2:00 AM – 5:00 AM
Affects
Payments & Card Service
Under maintenance from 2:00 AM to 5:00 AM
Completed
March 17, 2024 at 5:00 AMCompleted
March 17, 2024 at 5:00 AMMaintenance has completed successfully
In progress
March 17, 2024 at 2:00 AMIn progress
March 17, 2024 at 2:00 AMMaintenance is now in progress
Planned
March 17, 2024 at 2:00 AMPlanned
March 17, 2024 at 2:00 AMDue to essential maintenance being completed by our SEPA payments processor, there will be a SEPA network outage between 02:00 am (GMT) to 05:00am (GMT) on Sunday the 17th of March.
All SEPA payments submitted during this time will queue as SEPA Credit payments to be processed in the next SEPA Credit run.
We are sorry for any inconvenience this may cause.